Barpay Service Disruption

Incident Report for Barpay

Resolved

This incident has been resolved.
Posted Sep 14, 2022 - 14:20 UTC

Investigating

We are currently experiencing a service disruption.

Our team is working to identify the root cause and implement a solution.
Posted Sep 14, 2022 - 14:16 UTC
This incident affected: Barpay Order and Pay Administration Console.